Hoppas en användarguide hjälper dig även om du stöter på /usr/local/opt/pkg-config.

Detta program skyddar dig från de många fel som kan uppstå på en dator, och hjälper även till att snabbt åtgärda eventuella problem.

~ Uppdatering==> Uppdatera 2 föråldrade planer, resultat:openssl 1.0.1j_1, sqlite 3.8.7.3==> Uppdatera bort från openssl==> Ladda ner från https://downloads.sf.net/project/machomebrew/Bottles/openssl-1.0.1j_1.yosemite.bottle.tar.gzRedan nedladdat: /Library/Caches/Homebrew/openssl-1.0.1j_1.yosemite.bottle.tar.gzFel: SHA1 ffc47898c5c5599745b644c1889e473418a18d5aVerkligen: Håller inte medFörväntat: eac5e2d21af64224fc533ebb793b99a2aea434c7Arkiv: /Library/Caches/Homebrew/openssl-1.0.1j_1.yosemite.bottle.tar.Försök igen gzFör samtidigt ofullständig nedladdning, ta bort ovanstående katalog.Varning: Flaskfel: Bygg installationen direkt från källan.==> Installera openssl beroende: makedepend==> https://downloads downloading.sf.net/project/machomebrew/Bottles/makedepend-1.0.5.yosemite.bottle.tar.gzRedan nedladdat: /Library/Caches/Homebrew/makedepend-1.0.5.yosemite.bottle.tar.gzFel: SHA1 matchar inteFörväntad: 9a35ee27a96d2916dd347b362a2f62a3eb37b252Aktuell: eac5e2d21af64224fc533ebb793b99a2aea434c7Arkiv: /Library/Caches/Homebrew/makedepend-1.0.5.yosemite.bottle.tar.Försök igen gzofullständig nedladdning, ta bort duplicerat innehåll ovanstående fil.Varning: Flaskfel: inställningarna genereras från källkoden.Fel: /usr/local/opt/pkg-config.inte utmärkt eller fungerar inteVänligen installera om pkg-config. Förlåtelse :(
  • Snälla övertyga om att du svarade på frågan. Ge sanning och dosera din forskning!

  • Be om lättnad, förtydliga eller svara på andra frågor.
  • Uttalanden om den “välgrundade åsikten”; Stöd dem med bestämmelser eller personlig erfarenhet.
  • Fel: Undantag inträffade i underordnad process:  RuntimeError: /usr/local/opt/pkg-config är förmodligen inte tillgänglig och fungerar inteVänligen installera om pkg-config. Tyvärr :(
    Fel: pkg-config 0.29 har faktiskt installerats flera gångerFör att sätta 0.29.2, kör `brew unlink pkg-config` i början.
    configure: error: ./configure var inte lovande för DETTA: glibLÄS https://docs.brew.sh/Troubleshooting

    Presentation

    Det här inlägget är en sammanfattning kopplad till försöket att registrera min Postgresql-installation som Homebrew på macOS Mojave. Orsaken till felet hade oftast blivit en kommande uppgradering som motiverade en uppgradering från Postgres 12 som kan Postgres 13. Detta resulterade i varje anslutningsfel som hindrar mig från att ursprungligen komma in i min postgres lagringsmetod antingen på port 5432 eller från direkt svarsåtkomst via psql. .

    I alla fall fick jag att avinstallera och installera om en del av den exakta kompletta Homebrew.setup-installationen, som också använde ominstallation av Ruby och Jekyll, lika bra som imagemagick, ffmpeg, inkscape och andra applikationer kör under bryggning.

    Port 5432 svarar definitivt inte

    Systemkontroller

    Ett postgres-kommando som indikerar om någon sorts instans körs från en postgres-synpunkt:

    Starta om Postgres

    Postgres trädgårdsbygge stannar och startar, bara kontakten på port 5432 fortsätter att hänga.

    Postgres-loggfil

    Hur man åtgärdar Windows-krascher

    Körs din dator långsamt? Upplever du regelbundna krascher och frysningar? Då är det dags att ladda ner Reimage! Denna kraftfulla programvara reparerar vanliga Windows-fel, skyddar dina filer från förlust eller korruption och optimerar ditt system för maximal prestanda. Med Reimage kan du fixa alla Windows-problem med bara några klick - ingen teknisk expertis krävs! Så varför vänta? Ladda ner Reimage idag och njut av en smidig, stabil PC-upplevelse.

  • Steg 1: Ladda ner och installera Reimage
  • Steg 2: Starta programmet och välj den skanning du vill köra
  • Steg 3: Klicka på knappen Återställ och vänta tills processen är klar

  • I min produktion Postgres finns listan över loggar på:

    Så nästa steg i ett helt nytt enkelt försök att rädda Postgres webbplats var att installera om en åldrande, mer mogen version av Postgre.

    Ställa in den gamla Pstgres-typen

    Än så länge är det bra, även om du måste ta bort standardversionen först.

    Ta bort betalversion

    Kör varje postgress-alternativ (utfasad version) för att se om det fungerar

    Och senare, starta Postgres-servern, av anledningen att den här tjänsten kördes som standard:

    Med sekvenserna ovan tror jag att jag kommer att få det Killed Postgres, men den här situationen fungerar igen och förlorar allt innehåll.

    Psql fungerar inte

    Men jag kan inte anropa Postgres med psql för att ställa in evakuerings- och drivrutinslösenord.

    Flera stora frågor dyker upp, inklusive postgresql för 13.1, men det kan inte sägas något om det i nuläget.

    Psql är allvarligt nere och

    Precis som psql kan ingen tableplus komma åt postgres på internet och rapportera fel med openssl/libssl.

    Mycket information om. Jag har precis kommit igenom allt.

    [email protected]

    Efter att ha tittat lite mer, hittade jag en annan möjlighet att bygga openssl1.0, och detta gick åtminstone när som helst installationen som en openssl1:

    Add.0 för att hjälpa dig med PATH

    fel /usr/local/opt/pkg-config i motsats till nuvarande eller trasig

    Första terminalomstart, vid den tidpunkten ändrar inte maskinen någonting (psql-fel söker ofta efter openssl1.0 )

    Upprepa från början

    Vid det här tillfället startade jag om hela installationen, men den här gången satte jag in opnessl1.0 framför kopplat till Postgre. Därav denna sekvens av expertkommandon:

    error /usr/local/opt/pkg-config långt ifrån att vara närvarande eller trasig

    Den här gången verkar tillkomsten mer lovande. Men en posgresql-version bifogas inte (eftersom jag tog bort ovanstående IT). Jag försummar det och fortsätter genom att rensa bort openssl:

    Installera om Openssl1.0

    Nu blir jag galen om jag antar att just denna Postgres vill ha libssl.1.1. Så jag körde följande sekvens bakom kommandon:

    Installera om Homebrew

    Hela övningen som hänvisas till ovan slutade i totalt , orkestrerad av Homebrew. Jag var ineffektiv att göra eller förbereda en revidering. Så jag avinstallerade vår fullständiga hembrygginstallation enligt beskrivningen på sidan nitton i den här vyn.

    Jag tog bort alla nödvändiga kataloger från listan. Sedan installerade jag Homebrew från början.

    Installera Postgres webbläsare

    Starta om Postgres

    Starta en ny maskin och starta om Postgres för den här sidan.

    Begagnade sidor

    stackoverlfow – Det går inte att ansluta till Postgres-server som kör bryggtjänster

    stackoverflow – körs mycket värd på värdinnan “localhost” (::1) som accepterar TCP/IP-anslutningar i område 5432?

    stackoverflow – dyld: bibliotek inte installerat: /usr/local/opt/icu4c/lib/libicui18n.62.dylib stupidity kör php senare på noden snabbt och enkelt med brew onto – mac

    superuser Hur korrigerar man meddelandet “Biblioteket är inte fullt: libssl.1.0.0.dylib” som har PostgreSQL?

    Det gick inte att ansluta med hänsyn till servern: anslutningen nekadesHela servern skulle köras på värden "localhost" (127.0.0.1) men accepterar också anslutningar.TCP/IP på dockningsstation 5432?
    $psqldyld: biblioteket är inte staplat: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib  Länkad från: /usr/local/lib/libpq.5.dylib  Anledning: inte trickbilder: hittadesvägra 6
    $postgres/usr/local/bin/postgres

    Stoppa krascher och fel med Reimage reparationsguiden. Klicka här för att ladda ner.