Mam nadzieję, że podręcznik użytkownika pomoże ci wtedy, gdy natkniesz się na /usr/local/opt/pkg-config.

Ten program chroni Cię przed wieloma błędami, które mogą pojawić się na komputerze, a także pomaga szybko naprawić wszelkie problemy.

~ Aktualizacja==> Zaktualizuj 2 starsze pakiety, wynik:openssl 1.0.1j_1, sqlite 3.8.7.3==> Aktualizacja z openssl==> Pobierz z https://downloads.sf.net/project/machomebrew/Bottles/openssl-1.0.1j_1.yosemite.bottle.tar.gzJuż kupiłem: /Library/Caches/Homebrew/openssl-1.0.1j_1.yosemite.bottle.tar.gzBłąd: SHA1 ffc47898c5c5599745b644c1889e473418a18d5aRzeczywiście: nie zgadzam sięOczekiwane: eac5e2d21af64224fc533ebb793b99a2aea434c7Archiwum: /Biblioteka/Caches/Homebrew/openssl-1.0.1j_1.yosemite.bottle.tar.Ponów próbę gzPo każdym niepełnym pobraniu usuń niektóre z powyższych katalogów.Ostrzeżenie: Błąd butelki: budowanie asemblacji bezpośrednio ze źródła.==> Zainstaluj openssl Reliance: makedepend==> https://downloads downloading.sf.net/project/machomebrew/Bottles/makedepend-1.0.5.yosemite.bottle.tar.gzJuż pobrane: /Library/Caches/Homebrew/makedepend-1.0.5.yosemite.bottle.tar.gzBłąd: niezgodność SHA1Oczekiwane: 9a35ee27a96d2916dd347b362a2f62a3eb37b252Prąd: eac5e2d21af64224fc533ebb793b99a2aea434c7Archiwum: /Biblioteka/Caches/Homebrew/makedepend-1.0.5.yosemite.bottle.tar.Ponów próbę gzniekompletne pobieranie, usuń powyższy plik.Ostrzeżenie: Błąd butelki: instalacje są generowane z kodu witryny.Błąd: /usr/local/opt/pkg-config.not sugerowany lub nie działaZainstaluj ponownie pkg-config. Przebaczenie :(
  • Proszę przekonać Jestem optymistą, że odpowiedziałeś na pytanie. Podaj szczegóły i dozuj swoje badania!

  • Poproś o pomoc, wyjaśnij lub odpowiedz na wiele innych pytań.
  • Stwierdzenia „uzasadnionej opinii”; Wspieraj je za pomocą rekomendacji lub osobistych doświadczeń.
  • Błąd: Wystąpił wyjątek w procesie podrzędnym:  RuntimeError: /usr/local/opt/pkg-config jest niedostępny i nie obejmuje pracyZainstaluj ponownie pkg-config. Przepraszamy :(
    Błąd: pkg-config 0.29 został już zainstalowany wiele razyAby umieścić w 0.29.2, uruchom `brew unlink pkg-config` o początku.
    configure: błąd: ./configure był i nie jest możliwy dla TEGO: glibPRZECZYTAJ https://docs.brew.sh/Troubleshooting

    Prezentacja

    Ten post jest analizą wysiłków związanych z zarejestrowaniem naszej instalacji Postgresql jako Homebrew na macOS Mojave. Powodem niektórych błędów była zwykle nadchodząca aktualizacja, która niestety spowodowała aktualizację kuponów z Postgres whataburger do Postgres 13. Wynikało to z błędem połączenia, który uniemożliwia naszej firmie dostanie się do mojego systemu pamięci Postgres albo na porcie 5432 alias bezpośrednio dostęp odpowiedzi za pomocą psql. .

    W końcu musiałem odinstalować i ponownie zainstalować część większości kompletnej instalacji Homebrew.setup, która zdecydowanie zbyt wymagała ponownej instalacji Ruby i Jekyll, równie dobrze jak imagemagick, ffmpeg, inkscape i więcej inne aplikacje działające pod brew.

    Port 5432 zdecydowanie nie odpowiada

    Kontrole systemu

    Polecenie postgres, które wskazuje, kiedy instancja jest uruchomiona z naszego własnego punktu widzenia:

    Ponownie uruchom Postgres

    Budowanie poprawki Postgres zatrzymuje się i rozpoczyna, jedna komunikacja na porcie 5432 zabezpiecza zawieszenie.

    Plik dziennika Postgres

    Jak naprawić awarie systemu Windows

    Czy Twój komputer działa wolno? Czy doświadczasz regularnych awarii i zawieszeń? W takim razie czas na pobranie Reimage! To potężne oprogramowanie naprawi typowe błędy systemu Windows, ochroni pliki przed utratą lub uszkodzeniem i zoptymalizuje system pod kątem maksymalnej wydajności. Dzięki Reimage możesz naprawić każdy problem z systemem Windows za pomocą zaledwie kilku kliknięć - nie jest wymagana specjalistyczna wiedza techniczna! Więc po co czekać? Pobierz Reimage już dziś i ciesz się płynną, stabilną obsługą komputera.

  • Krok 1: Pobierz i zainstaluj Reimage
  • Krok 2: Uruchom program i wybierz skanowanie, które chcesz uruchomić
  • Krok 3: Kliknij przycisk Przywróć i poczekaj na zakończenie procesu

  • W moim zestawie Postgres lista logów znajduje się bez wątpienia pod adresem:

    Więc następnym krokiem w prostej próbie uratowania tej witryny Postgres była ponowna instalacja potężnej starszej, bardziej dojrzałej wersji Postgre.

    Ustawianie starego typu Pstgres

    Tak dobre mile, chociaż musisz najpierw usunąć domyślną wersję.

    Usuń wersję płatną

    Uruchom każdą opcję Postgress (przestarzała wersja), aby sprawdzić, czy działa

    A później uruchom serwer WWW Postgres, ponieważ ta usługa działała domyślnie:

    Wyobrażam sobie, że dzięki powyższym sekwencjom otrzymam Killed Postgres, ale działa znowu, tracąc prawie całą zawartość.

    Psql nie działa

    Ale nie mogę wyczarować Postgresa za pomocą psql, aby ustawić hasła domyślne i sterowniki.

    Powstało kilka dużych zapytań, w tym postgresql dotyczący 13.1, ale w tej chwili nie mogę nic powiedzieć o tym fakcie.

    Psql jest poważnie uszkodzony i

    Podobnie jak psql, żaden tableplus nie może łatwo uzyskać dostępu do postgres i zgłaszać błędy za pomocą tylko openssl/libssl.

    Mnóstwo informacji na temat. Po prostu przeskoczyłem przez to wszystko.

    [email protected]

    Po sprawdzeniu trochę więcej, znalazłem więcej alternatyw dla budowania openssl1.0 i rodzaju czasu, w którym przynajmniej instalacja przeszła przez openssl1:

    Dodaj 0, aby pomóc Ci ze ŚCIEŻKĄ

    błąd /usr/local/opt/pkg-config na pewno obecny lub uszkodzony

    Najpierw uruchom ponownie komputer, a następnie komputer niczego nie zmienia (błąd psql nadal szuka openssl1.0)< /p>

    Powtórz od początku

    W tym momencie zrestartowałem całą instalację, ale w tym czasie wstawiłem opnessl1.0 na początku Postgre. Stąd ta sekwencja wraz z poleceniami umiejętności:

    błąd /usr/local/opt/pkg-config nie występuje lub nie działa

    Tym razem każdy z naszych wyników wydaje się bardziej obiecujący. Ale zazwyczaj wersja posgresql nie jest dołączona (ponieważ usunąłem powyższe IT). Wyraźnie to zignoruję i kontynuuję przez animal openssl:

    Ponownie zainstaluj Openssl1.0

    Teraz idę obłędnie, jeśli ten konkretny Postgres jest określony jako libssl.1.1. Uruchomiłem więc następujący proces poleceń:

    Ponownie zainstaluj Homebrew

    Cała procedura opisana powyżej zakończyła się fiaskiem, zaaranżowanym przez Homebrew. Nie udało mi się wykonać lub przygotować silnej aktualizacji. Odinstalowałem więc naszą pełną instalację homebrew, jak opisano na arkuszu 18 tego widoku.

    Usunąłem z listy wiele ważnych katalogów. Następnie zainstalowałem Homebrew od zera.

    Zainstaluj przeglądarki Postgres

    Uruchom ponownie Postgresa

    Uruchom nowy komputer i uruchom ponownie Postgres dla tej strony.

    Używane strony

    stackoverlfow – Nie można skorelować z serwerem Postgres z uruchomionymi usługami make

    stackoverflow – czy host uruchomiony na ustawionym “localhost” (::1) akceptuje połączenia TCP/IP dotyczące pola 5432?

    stackoverflow – dyld: biblioteka prawdopodobnie nie jest załadowana: /usr/local/opt/icu4c/lib/libicui18n.62.dylib głupota uruchom właściwy węzeł php szybko i łatwo z włączonym piwem – mac

    superuser Jak na rynku naprawić komunikat „Biblioteka nie jest pełna: libssl.1.0.0.dylib” za pomocą PostgreSQL?

    Nie udało się skomunikować z serwerem: połączenie odrzuconeCała sieć działa na dostawcy hostingu internetowego „localhost” (127.0.0.1), a także otrzymuje płatności z połączeń.TCP/IP na stacji dokującej 5432?
    $psqldyld: biblioteka nawet nie załadowana: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib  Link do: /usr/local/lib/libpq.5.dylib  Powód: nie oszukać obrazów: znalezionoodmówić 6
    $postgres/usr/local/bin/postgres

    Zatrzymaj awarie i błędy za pomocą kreatora naprawy Reimage. Kliknij tutaj, aby pobrać.