Spero che questa guida personale ti aiuti quando qualcuno si imbatte in /usr/local/opt/pkg-config.

Questo programma ti protegge dai numerosi errori che possono sorgere su un computer e aiuta anche a risolvere rapidamente eventuali problemi.

~ Aggiorna==> Aggiorna 2 pacchetti obsoleti, risultato:openssl 1.0.1j_1, sqlite 3.8.7.3==> Aggiorna direttamente da openssl==> Scarica da https://downloads.sf.net/project/machomebrew/Bottles/openssl-1.0.1j_1.yosemite.bottle.tar.gzGià scaricato: /Library/Caches/Homebrew/openssl-1.0.1j_1.yosemite.bottle.tar.gzErrore: SHA1 ffc47898c5c5599745b644c1889e473418a18d5aInfatti: in disaccordoPrevisto: eac5e2d21af64224fc533ebb793b99a2aea434c7Archivio: /Library/Caches/Homebrew/openssl-1.0.1j_1.yosemite.bottle.tar.Retry gzPer entrambi i download ugualmente incompleti, eliminare la directory precedente.Avvertenza: Errore bottiglia: configurazione dell'edificio direttamente tramite sorgente.==> Installa la dipendenza openssl: makedepend==> https://downloads downloading.sf.net/project/machomebrew/Bottles/makedepend-1.0.5.yosemite.bottle.tar.gzGià scaricato: /Library/Caches/Homebrew/makedepend-1.0.5.yosemite.bottle.tar.gzErrore: mancata corrispondenza SHA1Previsto: 9a35ee27a96d2916dd347b362a2f62a3eb37b252Corrente: eac5e2d21af64224fc533ebb793b99a2aea434c7Archivio: /Library/Caches/Homebrew/makedepend-1.0.5.yosemite.bottle.tar.Retry gzdownload incompleto, elimina questo particolare file sopra.Avvertimento: Errore bottiglia: le installazioni verrebbero generate dal codice sorgente.Errore: /usr/local/opt/pkg-config.not offerto o non funzionanteReinstallare pkg-config. Perdono :(
  • Per favore, convinci, spero che tutti abbiano risposto alla domanda. Fornisci dettagli e dosa la tua ricerca!

  • Chiedi aiuto, dì o rispondi ad altre domande.
  • Dichiarazioni relative a “parere fondato”; Supportali con consigli ed esperienza personale.
  • Errore: si è verificata un'eccezione in un piccolo processo:  RuntimeError: /usr/local/opt/pkg-config probabilmente non è disponibile e non funziona nemmenoSi prega di reinstallare pkg-config. Siamo spiacenti :(
    Errore: pkg-config 0.29 è stato sicuramente installato più voltePer installare 0.29.2, lavora a `brew unlink pkg-config` all'inizio.
    configure: error: ./configure non era possibile quando QUESTO: glibLEGGI https://docs.brew.sh/Troubleshooting

    Presentazione

    Questo contenuto è un riepilogo dello sforzo esatto per registrare il mio edificio Postgresql come Homebrew su macOS Mojave. Il motivo dell’errore era generalmente un aggiornamento imminente che ha causato un nuovo aggiornamento da Postgres 12 a Postgres 13. Ciò ha provocato un errore tandem che mi impedisce di possedere frequentemente il mio sistema di archiviazione Postgres sulla porta 5432 o tramite un accesso di risposta preciso tramite psql . .

    Alla fine, ho dovuto rimuovere e reinstallare parte dell’installazione completata di Homebrew.setup, che richiedeva anche la reinstallazione di Ruby e Jekyll, nonché quando imagemagick, ffmpeg, inkscape e altri trattamenti in corso sotto brew.

    La porta 5432 sicuramente non risponde

    Controlli di sistema

    Un comando postgres che indica se l’incidente è in esecuzione dalla vista diretta di postgres:

    Riavvia Postgres

    La formula della patch Postgres si interrompe e si avvia, la comunicazione solo quando la porta 5432 continua a rimanere sospesa.

    File di registro Postgres

    Come risolvere gli arresti anomali di Windows

    Il tuo PC è lento? Stai riscontrando arresti anomali e blocchi regolari? Allora è il momento di scaricare Reimage! Questo potente software riparerà gli errori comuni di Windows, proteggerà i tuoi file da perdita o danneggiamento e ottimizzerà il tuo sistema per le massime prestazioni. Con Reimage, puoi risolvere qualsiasi problema di Windows con pochi clic, senza bisogno di competenze tecniche! Allora perché aspettare? Scarica Reimage oggi e goditi un'esperienza PC fluida e stabile.

  • Passaggio 1: scarica e installa Reimage
  • Passaggio 2: avvia il programma e seleziona la scansione che desideri eseguire
  • Fase 3: fai clic sul pulsante Ripristina e attendi che il processo finisca

  • Nella mia produzione Postgres, tipicamente l’elenco dei log è posizionato in:

    Quindi il passo successivo in un tentativo senza problemi di salvare Postgres online è stato reinstallare una versione vecchia e nuova di Postgre.

    Impostazione del vecchio tipo Pstgres

    Finora così alta qualità, anche se devi prima rimuovere la versione predefinita principale.

    Rimuovi versione a pagamento

    Esegui ogni opzione Postgress (versione obsoleta) per vedere se funziona

    E più tardi, avvia il server Postgres, poiché alcuni servizi erano in esecuzione per impostazione predefinita:

    Con le tue sequenze attuali sopra, penso che lo raggiungerò Killed Postgres, ma si esercita di nuovo, perdendo tutti i contenuti.

    Psql non funzionante

    Ma non posso invocare Postgres grazie a psql per impostare le password predefinite e poi quelle dei driver.

    Ci sono molte grandi domande, incluso postgresql per 13.1, ma non sarà in grado di dire nulla al riguardo in un momento specifico.

    Psql è seriamente inattivo e

    Come psql, nessun tableplus può accedere a postgres e segnalare errori utilizzando openssl/libssl.

    Un sacco di informazioni su. Ho appena saltato in tutto.

    [email protected]

    Dopo aver cercato un nulla di più, ho trovato un’altra alternativa come un modo per costruire openssl1.0, e questa volta insieme a almeno l’installazione è andata solo tramite openssl1:

    Add.0 per aiutarti con PATH

    error /usr/local/opt/pkg-config non fornito o rotto

    Primo riavvio del terminale, quindi l’auto non cambia nulla (l’errore psql continua a cercare openssl1.0)

    Ripeti dall’inizio

    A questo punto ho riavviato l’intera installazione, ma questa volta ho inserito opnessl1.0 davanti a Postgre. Da qui questa sequenza di comandi del know-how:

    error /usr/local/opt/pkg-config non prodotto o danneggiato

    Questa volta, il risultato sembra più promettente. Ma l’opzione posgresql non è allegata (perché ho rimosso l’IT sopra). Ignorerò chi è e continuerò rimuovendo openssl:

    Reinstalla Openssl1.0

    Ora sto impazzendo se questa situazione in particolare Postgres vuole libssl.1.1. Quindi ho eseguito la seguente sequenza di comandi:

    Reinstalla Homebrew

    L’intero esercizio sopra descritto si è concluso con un totale fallimento, orchestrato un Homebrew. Non sono stato in grado di effettuare o preparare un aggiornamento. Quindi ho disinstallato il nostro homebrew completo organizzato come descritto a pagina 18 con questa vista.

    Ho rimosso dall’elenco tutte le directory Internet importanti. Poi ho applicato Homebrew da zero.

    Installa i browser Postgres

    Riavvia Postgres

    Avvia una nuova macchina e riavvia Postgres per questa pagina.

    Pagine usate

    stackoverlfow – Impossibile connettersi al server Postgres che esegue i servizi brew

    stackoverflow – l’host è sempre in esecuzione sull’host “localhost” (::1) realizzando connessioni TCP/IP nella sfera 5432?

    stackoverflow – dyld: libreria non caricata: /usr/local/opt/icu4c/lib/libicui18n.62.dylib battiness esegui php dopo il nodo senza indugio e facilmente con brew to – mac

    superutente Come intervenire per correggere il messaggio “Library not full: libssl.1.0.0.dylib” con PostgreSQL?

    Impossibile connettersi al server web: connessione rifiutataL'intero server sta lavorando sull'host "localhost" (127.0.0.1), quindi accetta anche connessioni.TCP/IP relativo alla docking station 5432?
    $psqldyld: libreria non caricata: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib  Collegato da: /usr/local/lib/libpq.5.dylib  Motivo: immagini non ingannevoli: trovaterifiutare 6
    $postgres/usr/local/bin/postgres

    Ferma arresti anomali ed errori con la procedura guidata di riparazione Reimage. Clicca qui per scaricare.